Pause cutscene action delay

Slate Forums General Discussion Pause cutscene action delay

This topic contains 6 replies, has 2 voices, and was last updated by  mike670 6 days, 16 hours ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1129

    mike670
    Participant

    Hello,

    I have noticed when using the built-in pause cutscene action, there is a delay from triggering and having the actual cutscene pause.
    It is not consistent on how much the delay is. Without digging too far, I assume this is due to floating point precision.

    Any tips to mitigate this issue?
    Worst case I will have to pad the pauses.
    If it is the float issue, maybe a long term fix could be to convert the time types into milliseconds stored as uint64 or something.

    I attached an image of where the scrubber stops after hitting a pause action.

    Running:
    Unity 5.5.1f1
    Windows 7 64bit
    Latest version of Slate

    Thanks

    Attachments:
    You must be logged in to view attached files.
    #1136

    Gavalakis
    Keymaster

    Hey,
    Thanks for bringing this into my attention and very sorry for the late reply, but somehow I missed your post.
    The reason this is happening is because the OnEnter of an action clip is called after the time of the cutscene is already processed by deltaTime, and since deltaTime is variant this is also why this different is variant as well.
    The best way to work around this, would be to change the PauseCutscene.cs clip to the following code:

    Aparently, this will snap back and sample the cutscene time at the exact time of the action clip start time. 🙂

    Cheers!

    #1137

    mike670
    Participant

    Worked perfectly, thanks 🙂

    #1142

    Gavalakis
    Keymaster

    Thanks for letting me know.
    I am glad it worked for you 🙂
    This change will be included in the next version as well!

    #1159

    mike670
    Participant

    I found an issue with this, if you have a sub cutscene with pauses in it, and skip to after it in the main cutscene, everything will hang for the duration of the sub cutscene.

    #1165

    Gavalakis
    Keymaster

    Hey,

    Sorry for the late reply.
    Hmm. The PauseCutscene should not work/pause a sub-cutscene in the first place, since the sub-cutscene is not considered to be playing, but rather it only get’s sampled by it’s parent cutscene, thus ‘root.Pause()’ does not have any effect. This is weird 🙂
    Can you please provide a bit more information of the setup you have and calls you do, so that I can understand better what you mean?

    Thanks in advance!

    #1168

    mike670
    Participant

    Oh right, I forgot I changed it so it does pause the cutscene, my own issue then. Thanks.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.